Trevor Sullivan's Tech Room

Minding the gap between administration and development

MDT 2010 Driver Injection Slowness

Posted by Trevor Sullivan on 2009/10/27


After upgrading from MDT 2008 to 2010, I recently experienced an issue with MDT / WinPE 3.0 that was simply a driver issue. The initial symptom reported to me was: Driver detection / copying (ZTIDrivers.wsf) is taking a long time in WinPE on a Lenovo T60. The build completed, but hung on the driver injection step for about an hour.

To start diagnosing, I booted WinPE 3.0 off of USB flash drive (UFD) on a Lenovo T60, brought up a command prompt (press F8) and tried to browse the disk (just by typing “c:”) I got: “The volume does not contain a recognized file system. Please make sure that all required file system drivers are loaded and that the volume is not corrupted.” Upon issuing “format fs=ntfs quick” to diskpart, I received: “DiskPart has encountered an error: The parameter is incorrect. See the System Event Log for more information.” Running “ipconfig” yielded normal results, and I was also able to mount network shares, and browse them without any issue.

Note: I typically use a UFD because they boot significantly faster than off of optical media. 🙂

After posting on the MDT-OSD discussion list on MyITforum, I discovered that I may not have the correct drivers in my boot image. Most other people have reported that they haven’t had to inject any drivers, and I figured that the Vista drivers I had in my old WinPE 2.x boot images should have worked alright. As it turns out however, the Intel NIC was using a built-in driver from Microsoft according to wpeinit.log, and there was no mass storage driver being loaded according to the output from “devcon driverfiles *“.

Resolution

So, simply updating the mass storage and NIC drivers resolved the issue(s). The network drivers can be found here: http://www.intel.com/support/network/sb/cs-006120.htm. The storage drivers can be found here: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=17882&lang=eng.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: